PhysioToolkit binaries for Linux

This directory contains packages of PhysioToolkit software that have been precompiled for x86 Linux. Most of these packages are available as gzip-compressed tar archives (.tar.gz files) and as binary RPMs (.i?86.rpm files).

If your Linux installation includes RPM, the easiest way to install these binaries is to download and install binary RPMs. The source RPMs (.src.rpm files) do not contain binaries, but can be used to create binaries automatically if your system is equipped with the rpm utility.

All PhysioToolkit software is freely available in source form. You are encouraged to download the sources, compile them, study them, and modify them to suit your needs.

Installing the WFDB Software Package from binary RPMs

Beginning with version 10.3.2, the WFDB software package is now available as five component RPMs (six beginning with 10.3.12); it is no longer necessary to install the entire package under GNU/Linux. The packages are:

Find the RPMs you need in the listing below and download them. The key needed to verify RPMs from this site made after March 2008 can be added to your keyring using the command

rpm --import

If you have not already done so, download and install the curl-devel and XView RPMs. Then install the WFDB RPMs you have downloaded using a command such as

rpm -Uvh wfdb*rpm

(You will need root permissions to install any of these RPMs.)

This software is also available as a source RPM (see below), or as a gzip-compressed tar archive of sources. Warning: rebuilding the source RPM will update /usr/lib/ and /usr/include/wfdb/*.h to the versions contained in the RPM.

Version 10.2.3 and later packages are considerably smaller than previous versions, primarily because redundant copies of the figures in the WAVE User's Guide have been removed in these newer versions (scripts are provided for generating these figures if needed).

Important note for Fedora and other version 2.6 kernel distributions

Please be sure to install the XView RPMs for Fedora; the older versions of these RPMs are not stable under Fedora. The Fedora RPMs should also be usable with RHL 8.0 and later.

If you wish to install a version of the WFDB RPM older than 10.3.0, you will need to remove the epic package if it is installed. (Red Hat Linux 8.0 includes a new IRC (chat) client called epic. The epic and the older wfdb packages both include applications installed as /usr/bin/epic, so they cannot coexist. In WFDB 10.3.0, this conflict has been resolved by renaming epic as epicmp.)

Alternative methods for installing WFDB binaries

If you don't have the RPM utility, individual binaries may be downloaded from the wfdb directory. These binaries were compiled from the WFDB Software Package, specifically from the sources for the version indicated as current in the listing below.

The most recent binaries were compiled under Fedora 8 and linked against glibc 2.7.2 and libcurl 7.17.1. Previous sets of binaries (in old) were linked against earlier versions of glibc and libcurl or libwww; these may be usable with older GNU/Linux distributions.

In order to use any of these binaries, you must have installed the version of the WFDB library that accompanies them, the appropriate libcurl or libwww libraries, and (for WAVE only) the XView libraries.

To install the WFDB library needed by the binaries in bin, you will normally need root permissions. Download, save it in one of the directories named in /etc/ (/usr/lib is recommended), cd to that directory, and type:

ln -s
ln -s

If you don't have root permissions, install the library into any directory of your choice, make the symbolic links as above (omit the ldconfig), and add the name of the directory to your LD_LIBRARY_PATH environment variable.

Icon  Name                             Last modified      Size  Description
[DIR] Parent Directory - [   ] wfdb-doc-10.5.8-1.i586.rpm 12-Mar-2011 18:39 24M man page [   ] plt.src.rpm 27-Apr-2005 19:06 3.8M source RPM [   ] plt-2.4-3.src.rpm 27-Apr-2005 19:06 3.8M source RPM [   ] wfdb-10.5.8-1.src.rpm 12-Mar-2011 18:39 1.9M source RPM [   ] wfdb-10.5.8-i686-Linux.tar.gz 11-Mar-2011 14:37 601K gzip-compressed tar archive [   ] wfdb-app-10.5.8-1.i586.rpm 12-Mar-2011 18:39 438K man page [   ] wfdb-devel-10.5.8-1.i586.rpm 12-Mar-2011 18:39 293K man page [   ] wfdb-debuginfo-10.5.8-1.i586.rpm 12-Mar-2011 18:39 119K man page [   ] plt.x86_64.rpm 27-Apr-2005 18:57 113K binary RPM for Opteron [   ] plt-2.4-3.x86_64.rpm 27-Apr-2005 18:57 113K binary RPM for Opteron [   ] plt.i386.rpm 27-Apr-2005 19:06 99K binary RPM for x86 [   ] plt-2.4-3.i386.rpm 27-Apr-2005 19:06 99K binary RPM for x86 [   ] wfdb-wave-10.5.8-1.i586.rpm 12-Mar-2011 18:39 97K man page [   ] wfdb-10.5.8-1.i586.rpm 12-Mar-2011 18:39 45K man page [TXT] local.css 02-Oct-2015 18:29 3.1K C# source file [   ] RPM-GPG-KEY-gbm 09-Apr-2008 20:06 1.6K [TXT] CURRENT-WFDB-IS-10.5.8 12-Mar-2011 19:30 0 man page [   ] CURRENT-PLT-IS-2.4 27-Apr-2005 02:32 0 [DIR] wfdb/ 11-Mar-2011 14:37 - [DIR] wfdb-10.5.8-i686-Linux/ 11-Mar-2011 14:37 - man page [DIR] old/ 12-Mar-2011 19:18 -

Questions and Comments

If you would like help understanding the content of this page, or using and downloading data/software, please see our Frequently Asked Questions.

If you have any comments, feedback, or particular questions regarding this page or our website, please send them to the webmaster.

Updated Wednesday, 15 June 2016 at 10:08 BRT

PhysioNet is supported by the National Institute of General Medical Sciences (NIGMS) and the National Institute of Biomedical Imaging and Bioengineering (NIBIB) under NIH grant number 2R01GM104987-09.