WFDB_tools: A Matlab interface to the WFDB library

This package is obsolete and no support is available for it. The recommended and supported way to access PhysioBank data from the Matlab environment is via the WFDB Toolbox for Matlab. Several alternatives are discussed on our Matlab software page.

This package of software was written by Jonas Carlson, who has contributed it to PhysioNet for free use and redistribution. The WFDB_tools package allows Matlab R13 (a.k.a. 6.5) users to use the WFDB library to read and write digitized signals and annotations such as those available from PhysioBank.

The 00README file contained within the package provides instructions for installing WFDB_tools under MS-Windows, Linux, MacOS X, and other versions of Unix. (Installation has been tested under Linux, MacOS X, and MS-Windows XP only.) Please see the WFDB_tools manual for further information.

If you use Matlab under MS-Windows: MEX dll files compiled using Cygwin gcc, such as those provided in the windows directory of the WFDB_tools pacakge, can crash Matlab if reloaded (see this note for details). Also note that MEX files compiled using Cygwin gcc 3.3 can crash Matlab; this problem does not occur with Cygwin gcc 3.2 (see this page for further information). These are generic problems and are not specific to WFDB_tools.

If you use Matlab R12 (a.k.a. 6.1) or earlier: These wrappers will not work, and cannot be made to work, with R12 or older versions of Matlab, because they depend on capabilities first introduced in R13. Either upgrade to R13, or try one of the other methods to read and write PhysioBank and compatible data.

If you use Matlab R14 (a.k.a. Matlab 7.0) or MS Windows XP: We have received reports that the precompiled versions of the WFDB_tools wrappers may fail when using Matlab R14 under MS Windows XP. It is unclear if the problem is related to Matlab or to MS Windows. The Mathworks web site may have additional information about the compatibility of modules compiled for R13 (as provided here) with R14. In general, these are said to be compatible, but there are known issues with certain CPU types (Intel Celeron, AMD Duron, and possibly others) under at least some versions of MS Windows. If you have problems using the precompiled wrappers under MS-Windows, please try compiling them from the sources using Cygwin gcc 3.2 (not 3.3, see above), and let us know what you find out.